You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Bump pydantic, azure-servicebus and aiolimiter - #445
Current core dev-branch includes a bump of pydantic, so we need to include this in 0.8.8 @sveinse. @rhammen mentions testing azure-servicebus==7.15.0 in #442 (comment), so that should be ok as well. Aiolimiter appears to barely be updating anything, other than dropping python 3.9.
Hassfest test fails due to "Requirement azure-servicebus==7.15.0 is incompatible with azure-servicebus==7.10.0, which Home Assistant depends on." HA core dev-branch has already updated to 7.15 in home-assistant/core@c44cc4e, so that should stop failing once we hit HA 2026.11.0. Not sure why this test hasn't failed before, since we have been on 7.14 as long as I can remember, and the 7.10-requirement was added in May 🤷
Heads-up: even with HA 2026.11 (core already on 7.15.0), azure-servicebus==7.15.0 will still fail hassfest. The same check also rejects exact == pins on packages HA itself depends on, even when the versions match:
Requirement azure-servicebus==7.15.0 pins a package Home Assistant depends on (azure-servicebus==7.15.0). Use a minimum version ("azure-servicebus>=7.15.0") instead, ...
So I'd suggest "azure-servicebus>=7.15.0" (or >=7.15.0,<8 if we want an upper bound), plus requiring HA 2026.11+.
Why it only started failing now: the check was added in home-assistant/core#181913 (merged 2026-09-14), and the hassfest:latest image only gets it from 2026.10.0b0 (2026-09-30), so our first run after that, on 2026-10-05, failed while still on 7.14.3.
Interesting. I've updated all manifest.json deps to be a range. aiolimiter does not appear in HA requirements_all.txt (yet), but staying consistent seems reasonable, and it might get added in the future.
I don't think requiring HA 2026.11+ makes sense:
It means noone will be able to upgrade the zaptec integration until 2026.11.0 is released.
As far as I can tell, only the Azure Sevice Bus-integration requires the azure-servicebus-package, and it is listed as being used in a grand total of 4 installation (which could explain why we've never heard of any issues with incompatible versions)
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Current core dev-branch includes a bump of pydantic, so we need to include this in 0.8.8 @sveinse. @rhammen mentions testing azure-servicebus==7.15.0 in #442 (comment), so that should be ok as well. Aiolimiter appears to barely be updating anything, other than dropping python 3.9.
Hassfest test fails due to "Requirement azure-servicebus==7.15.0 is incompatible with azure-servicebus==7.10.0, which Home Assistant depends on." HA core dev-branch has already updated to 7.15 in home-assistant/core@c44cc4e, so that should stop failing once we hit HA 2026.11.0. Not sure why this test hasn't failed before, since we have been on 7.14 as long as I can remember, and the 7.10-requirement was added in May 🤷